Ana səhifə

Labview 0 Hangs When I place a matlab script Node or Load a VI that Already Contains a matlab script Node


Yüklə 5.59 Kb.
tarix23.06.2016
ölçüsü5.59 Kb.
LabVIEW 7.0 Hangs When I Place a MATLAB Script Node or Load a VI That Already Contains a MATLAB Script Node

Product Group: LabVIEW Software

Product Name: LabVIEW

Version/Revision: 7.0

Problem: LabVIEW 7.0 hangs when I place a MATLAB Script node on the block diagram or when I load a VI that already contains a MATLAB Script node. I have seen this behavior on Windows 2000 with MATLAB 6.1 or 6.5.

Solution: A Windows update might have caused this issue. To resolve this problem, you must update the matscript.dll to version 7.0.0.2 (attached below).

Use the attached DLL only if you are experiencing this problem. If you are not having any problems with LabVIEW 7.0 and MATLAB, you do not need to update the DLL.

Complete the following steps to update the DLL.


  1. Quit LabVIEW and MATLAB.

  2. Navigate to ..\Program Files\National Instruments\LabVIEW 7.0\resource\script.

  3. Move the old version of the matscript.dll (version 7.0.0.1) to a backup location in case you need it for future use.

    Note: If you leave the old DLL in this directory, you might experience erratic behavior.

  4. Detach the new DLL (attached below) into the script directory.

  5. Open LabVIEW 7.0.

  6. Place a MATLAB Script node on the block diagram. The problem should be resolved.

If using the MATLAB Script node in built applications you will need to also replace the DLL located in the ..\Program Files\National Instruments\shared\LabVIEW Run-Time\7.0\script directory.



Refer to the NI Developer Zone forum topic linked below for more information about this issue.


Verilənlər bazası müəlliflik hüququ ilə müdafiə olunur ©kagiz.org 2016
rəhbərliyinə müraciət